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Thank you for purchasing ESTUN robots.  

Before using the robot, be sure to read the SAFETY PRECAUTION and understand the contents. 
ESTUN endeavor to improve the products. All specifications and designs are subject to change without 
notice. 
All statements, information and advice provided in this manual have been carefully processed, but no 
guarantee is given for their completely accuracy. We shall not be held liable for any direct or indirect 
losses arising from the use of this manual. 
User are solely responsible for the application of any product and should exercise caution when using 
this manual and the associated product. 
The interpretation of all content in this manual belongs to Nanjing ESTUN Robotics Engineering Co., 
Ltd.  
 

 

 

 

 

 

 

 

 
 
 
 
 
 
 

No part of this manual may be reproduced in any form. 
ESTUN Robotics. All Rights Reserved Copyright. 
Service Hotline: 400-025-3336 
Address: No.1888, Jiying Avenue, Jiangning Economic Development Zone, Nanjing, China  
Postcode: 211102 
Telephone: 025-81031813 
Website: www.ESTUN.com 
Email: robot@ESTUN.com 

SAFETY  
This Chapter describes the precautions which must be followed to ensure the safe use of the robot. 

Before using the robot, be sure to read this chapter thoroughly. 
ESTUN robots must be transported, mounted and operated in accordance with national laws, 

mailto:robot@estun.com
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regulations and standards. Appropriate safeguards must be correctly performed to protect the users. 
Before using (mounting, operating, maintaining, repairing) the robot, be sure to read and understand 
this manual and its relevant manuals. Be sure to have familiarization with the knowledge of robot 
system and the safety precaution. Even if all instructions are followed, this is not a guarantee that the 
robot will not cause injuries or damage. 

 

DEFINITION OF USER 
The personnel can be defined as follows. 
 Operators 

Turns the robot power ON/OFF. 
Start the robot program from the panel. 

 Programmers 
Operates the robot; 
Teaches the robot inside the safety area; 

 Maintenance engineer 
Operate the robot; 
Teaches the robot inside the safety area; 
Maintenance (repair, adjustment, replacement). 

Operators must not awork in the safety area. 
Programmer and maintenance engineer can work in the safety area. 
During operation, programming and maintenance of the robot, the operator, programmer, and 

maintenance engineer should take precautions to ensure the safety by wearing the following safety 
items.: 

 Clothes for operation 
 Safety shoes 
 A helmet 

SPECIAL TRAINING 
Tasks in the safe area including transportation, setting, teaching, adjustment, maintenance, etc. 
Training course must be performed before operating the robot. 
For more information about training course, contact ESTUN. 

DEFINITION OF SAFETY NOTATIONS  
Precautions and information are defined as follows. 
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Symbol Definition 

 

Danger 
Death or serious injury will be expected to occur if the user fails to follow the 
approved procedure. 

 

Caution 
Minor or moderate injury of the user or equipment damage will be expected to 
occur if the user fails to follow the approved procedure. 

IN FO

 

Information 
A supplementary explanation helps users operating the robot more efficiently. 

Safety OF THE USER 
(1) The robot should be transported and installed as procedures recommended by ESTUN. Wrong 

procedures may cause severe injuries or damage due to the robot fall. 
(2) Draw an area clearly indicates the safety area. Install a fence or hang a warning board to ensure 

the safety operation of the robot, and keep unauthorized personnel outside the safety area. 
(3) Never hang any tools above the robot. Falling of these tools may cause damage to equipment. 
(4) Never lean on the cabinet. Never touch any buttons without permission. Unexpected movement of 

the robot may cause personnel injuries and equipment damage. 
(5) Take precautions for falling parts to avoid injuries when disassemble the robot. 
(6) Turn off the power when adjusting peripheral equipment. 
(7) Peripheral equipment must be grounded. 
(8) The robot should be operated in a low speed in the first operation. The speed should be added 

gradually to check if there is any abnormal situation. 
(9) Do not wear gloves when using the teach pendant. Operate with gloves may cause an operation 

error. 
(10) Programs, system variables, and other information can be saved on the memory card or USB 

memories. Be sure to save the data periodically in case that the data is lost. 
(11) Never forcibly move any axis of the robot. Move the axes forcibly may cause injuries or damage. 
(12) Take precautions when wiring and piping between the robot, the cabinet, and peripheral 

equipment. Put the pipes, wires or cables through a pit or covered with a protective lid, to avoid 
stepped by personnel or run over by a forklift. 

(13) Unexpected movement may occur on any operating robot, which will cause severe injuries or 
damages in the working area. Test (safe door, brake, safe indicators, etc.) must be performed on 
each safety measures before using the robot. Before turn on the system, make sure that no one is 
in the working space. 

(14) Never set motion range or load condition exceeds the rated range. Incorrect setting may cause 
personnel injury and equipment damage. 

(15) Observe the following precautions when teaching inside the working space of the robot 
 Do not enable the system unless the mode is switched to manual, and make sure that all 

auto-control is cut off. 
 Speed must be limited under 250mm/s at manual mode. Only authorized person with fully 

understand of the risks can adjust the robot to rated speed manually. 
 Be careful about rotating joints to prevent hair and clothes involved. Take precautions of injury 

or damage caused by the manipulator or other auxiliary devices. 
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 Check the motor brake to avoid personnel injuries caused by unexpected situation. 
 Always have an escape plan in mind in case the robot comes towards you unexpectedly. 
 Ensure that there is a place to retreat to in case of emergency. 

 

Never stand beneath the in case of unexpected movement or the system be 
turned on inadvertently. 

 

 
Make sure there is a CO2 fire extinguisher at hand. 

SAFETY OF OPERATORS:  

(1) Before operating the robot, check that the SERVO ON indicator goes out when the EMERGENCY 
STOP button on the right of the front door of the controller and the pendant are pressed. And 
confirm that the power is turned off. 

(2) Never allow unauthorized personnel to touch the controller during operation. This may result in 
unexpected movement of the robot, severe injuries and material damage. 

(3) When attaching tools to the robot, be sure to turn off the power of the controller and the peripheral 
equipment, and display a warning sign. Turning the power on during equipment installation may 
cause electric shock or injury due to unexpected movement of the robot. 

(4) E-stop 
Emergency stop is an external button of the controller that can stop the robot operation.  
When emergency button is pressed, the power of the robot (except the power of the servo) is cut 

off. The system will not run unless the pressed emergency button being released and the system being 
turned on. 

 

There are several emergency stop buttons in a robot system to stop the robot in 
case of emergencies. The red button, as shown in the left figure, can be mounted 
on the teach pendant and the controller. Certainly, the emergency buttons can be 
mounted by special requirement. 
Emergency stop button should be mounted where is easy to reach, so that the 
buttons can be pressed down immediately in case of emergencies. 

 

 

Emergency button is used in case of emergency only. Do not use it to stop the 
robot for normal operation. 

 

 

Operators must take precautions to avoid high voltage from cables of servo 
motors, grippers and other devices. 

SAFETY OF PROGRAMMERS: 

While teaching the robot, the programmer must enter the robot operation area. The programmer 
must ensure the safety especially. 
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Turn on or off the system by press or release Mot button on the teach pendant. 
When pressing this button, the servomotor is enabled, and disabled when 
releasing it. 

To ensure the safe use of the teach pendant, the following precautions should be taken: 
 Be sure that the enable switch is effective at any time. 
 Turn off the enable switch when pausing, programming or testing the system. 
 Teach pendant must be taken with the programmer when teaching in the work space, to avoid 

inadvertent operation by unauthorized person. 
 Teach pendant must not be left within the working space of the robot, as injury or damage can 

occur if the robot comes in the contact with the teach pendant. 
 

SAFETY OF MAINTENANCE ENGINEERS: 

(1) Heated parts 
Some parts of the robot are heated when robot is operating, especially the servo motor and 

reducer. If a maintenance engineer needs to touch such a part, the user should wear heat-resistant 
gloves or use other protective tools. 

 

Try to feel the temperature of heated parts before touching them, to avoid burn 
injuries. 
After turning off the power supply, wait until the heated parts cool down before 
performing any maintenance. 

(2) Disassembly parts 
Open the cover or shell only after interior parts such as gears are not moving any more. Never 

open the cover or shell when the gear or bearing is moving. Use auxiliary device to keep interior part to 
its position. 

Observe the following precaution when performing the first test after installation, inspection or 
maintenance: 

a) Clear tools to proper locations outside of the working space of the robot. 
b) Make sure that all precaution measures are available. 
c) Make sure that there is no one in the working space of the robot. 
d) Pay special attention to working condition of the maintenance parts when performing test. 
Never use the manipulator as a ladder when performing maintenance. Never climb on the 

manipulator to avoid falling down. 
(3) Pneumatic / hydraulic pressure 

There may be air/liquid residue in the system when the air pump or hydraulic pump is turned off. 
Before checking the pneumatic or hydraulic parts, release remaining pressure from the system to 
avoid personnel injury or equipment damage. 

 
Install a safety valve in case of accident. 

(4) Although the power supply need to be turned on during fault diagnosis, it must be turned off when 
perform maintenance. 

(5) Brake inspection 
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Brake may be wearing in daily operation. So brake inspection should be performed by the 
following procedure 

a) Move each joint to the position where the joint bears maximum load. 
b) Turn off the robot. The brake works. 
c) Mark each joint. 
d) Check if the joint moves over a period of time. 

(6) Greasing 
Personnel injury or equipment damage may occur during greasing. Observe the following 

precautions before greasing. 
 Take additional care of safety by wearing safety items (such as gloves) to avoid injury from 

heated oil or reducer. 

 Open the oil chamber with caution and keep away from the opening. Oil may spray due to oil 
pressure. 

 Feed the oil according to required quantity and never fill up the oil chamber. Check the oil 
indicator when finished. 

 Never mix different types of oil into one reducer. Clean the oil chamber thoroughly before 
changing oil type. 

 Oil draining must be performed thoroughly. Check the oil indicator when finished. 

IN FO

 
Operate the robot for a short period of time before oil draining to heat the oil. 

SAFETY OF THE TOOLS AND PERIPHERAL EQUIPMENT 
Peripheral device may still be running even after the system has been turned off. Personnel injury 

may occur due to damaged power lines. 

SAFETY OF THE ROBOT MECHANICAL UNIT 
For abnormal or emergency situations, e.g. persons trapped in or pinched by the robot, the robot 

axes should be moved. (Contact ESTUN for more details about dismantling). 
Small arms can be moved by hand. Lager arms should be moved by crane or other handling 

equipment. 
Fasten the robot firmly before releasing the brake to avoid secondary injury caused by falling 

arms. 

STOP TYPE OF ROBOT 
There are three types of robot stop. 

Power-Off Stop 

Servo power is turned off and the robot stops immediately. Servo power is turned off when the 
robot is moving, and the motion path of the deceleration is uncontrolled. 

The following processing is performed at Power-Off stop: 
 An alarm is generated and servo power is turned off, and the robot operation is stopped 
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immediately. 
 Execution of the program is paused. 
Frequent Power-off stop of the robot during operation can cause failures of the robot. Avoid 

system designs that require routine or frequent Power-off stop conditions. 

Alarm Stop 

The robot system sends alarm (not include power-off alarm), and the robot is decelerated until it 
stops by control instructions. 

The following processing is performed at Alarm stop:  
 An alarm (not include power-off alarm) is generated due to overload, system faulty, etc. 
 Control instruction is send from servo system. The robot operation is decelerated until it stops. 

Execution of the program is paused. 
 Servo power is off. 

Hold 

The robot is decelerated until it stops, and servo power remains on.  
The following processing is performed at Hold: 
 The robot operation is decelerated until it stops. Execution of the program is paused. 
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LABELS (1) Electric shock Warning 

 

Figure 0.1 Electric shock warning sign 

This label indicates hazardous voltage or electric shock. 

(2) High-temperature Warning 

 

Figure 0.2 High temperature warning sign 

Be cautious about a section where this label is affixed, as the section generates heat. If you have 
to inevitably touch such a section when it is hot, use a protective provision such as heat-resistant 
gloves. 

(3) No Step-on Warning 

 

Figure 0.3 Step-on prohibitive Warning 

Never step on or climb the robot or controller as it may adversely affect the robot or controller and 
may get hurt if you lose your footing as well. 
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(4) Personal Injury Warning 

 
Figure 0.4 Personal Injury Warning 

Never enter the operation area while the Manipulator is moving. This is extremely hazardous and 
may result in serious safety problems. 

(5) No Disassembly Warning 

 

Figure 0.5 No Disassembly Warning 

Never perform disassembly arbitrarily where the warning is affixed. Contact ESTUN for 
disassembly. 
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PREFACE 
This document provides a breakdown of the software functions of EditorP programming software 

and provides a brief explanation of each functional module. It is intended to assist operators in 
understanding the software. 
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1. User Management System 

1.1. Login Interface 
Upon system startup, there is a login window where users can enter their username/password to log in 
or choose to cancel the login. Canceling the login will result in logging in with limited guest privileges by 
default. 

 

 Username/Password: The Root account is provided by ESTUN, while other accounts are created 
by the administrator. For more details, please refer to Section 1.3. 

 Auto Login: When selected, the software will automatically log in with the last used account and 
password the next time it is opened (remember password must also be selected, otherwise 
logging in without a password will not be possible). 

 Remember Password: To save the currently entered username and password. 

 Change Password: To allow users to change their password by providing the username and old 
password. 

 

1.2. Switch User 
Clicking the first menu option in the menu bar "Username", you can swich the User, Log Out and 

User Management (only available for Root users).  
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 Switch User: To open the user login window to switch to a different user by entering the 
username/password. 

 Log Out: Log out the currently logged-in user and switch to guest privileges. 

 User Management: This option is available only for Root users and allows them to manage user 
accounts, including adding, deleting, and modifying user information. 
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1.3.  User Management 
 This module is exclusive to Root users. 

Username: Root  Initial Password: 000000 

 
 Add User: To create a new user account. Usernames must be unique. 
 Edit User: To allow for modifications to user permissions and passwords. 
 Delete User: To delete a specific user account. 
 Permission Levels: The following permission levels are defined as follow: 

 Guest: 
 Editing or viewing workspace content is not allowed. 
 Operating robot controls is not allowed. 
 Operating simulation models is not allowed. 

 Operator: 
 Same restrictions as the Guest level. 

 Engineer: 
 No user management is allowed, and full access to other features. 

 Administrator: 
 No user management is allowed, and full access to other features. 
 Root users have user management privileges. 
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2. Controller Module 

2.1. Controller Connection 

 
 Clicking on the red button circled in the above image will open the following connection dialog. 
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2.1.1. Virtual Controller 

、 

Choose the model according to needs and click the "Select" button to establish a connection. The 
startup time for the virtual controller is longer compared to an actual controller. This is because it 
requires launching a virtual controller on the computer, whereas with a physical controller, this step is 
unnecessary. 

Successful connection is indicated as shown in the following image 

 

 After connecting to the virtual controller, it will automatically enable and switch to manual mode, 
while adjusting the robot's initial posture. 
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Initialized Axis Coordinates: 0, 0, 0, 0, 90, 0 

2.1.2. Actual Controller 

For an actual controller, modify the IP address of the controller and click "OK". 

 
If the IP address is correct, wait a few seconds for the connection to succeeed. 

 

 After a successful connection, the connection button will turn green, and some buttons will 
become available. 
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Scan Controller: The scan range can be modified. 

 

2.2. Controller Disconnection 
After establishing a connection with the controller, you can click the "Connected" button to 

disconnect from the controller. If it is a virtual controller, the background virtual controller will also be 
closed. 
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After disconnecting, the status is as follows: 

 

2.3. Robot Control Module 
After establishing a connection with the controller, the robot control module allows you to operate 

the robot. The robot control module, along with the software's bottom status bar, displays the current 
status of the controller. 

The controller operation module includes the following buttons: 

"Enable": To enable or disable the controller. 

"Reset": To reset any errors in the controller. 

"System": To switch between manual and automatic mode. 

"Single Step/Cycle": To specify whether to run in single step mode or cycle mode. 
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"Start": To start the program execution. 

"Pause": To pause the program execution. 

"Stop": To stop the execution and unloads the program. 

 
The status bar displays the following information: 

1 Controller error messages. The "Reset" button above is used to reset any errors in the 
controller. 

2 Controller IP address. (Shows "Virtual Controller" when connected to a virtual controller or the 
current connected IP address for an actual controller.) 

3 Controller model. 

4 Controller speed. 

5 Controller running status, which can be divided as "Run", "Pause" or "Stop". The "Start", 
"Pause", and "Stop" buttons are associated with this running status. 

6 Controller tool coordinate system, which can be set manually or within the program. 

7 Controller user coordinate system, which can be set manually or within the program. 

 

2.4. Connect the Teach Pendant 
Ensure that the controller is already connected. 
1. Ensure that the controller is already connected. 

 
2. Start the Teach Pendant. 
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3. Open the Teach Pendant. 

 
 

 

2.5. Introduction to the Main UI Functions of the Editor 

Software 
The following image shows the main UI interface of the software: 



 

 
 

9 

 

 

1. Tab 1: Controller Connection, including physical controllers and virtual controllers. 

2. Tab 2: Local Programs, including text-based programs and graphical programs. 

3. Tab 3: Programs on the controller. 

4. Tab 4: Used primarily for debugging information, displaying error messages, breakpoints during 
program execution, bookmarks for code search, variable monitoring during program execution, 
program lists, and search results for specific keywords, distributed across each tab. 

5. Tab 5: Status Bar Functions, primarily displaying warning messages, IP address, robot model, 
speed, program execution status, and coordinate parameters. 

6. Tab 6: Used primarily for text editing, graphical editing of IO, 3D simulation display, and manual 
control. 

7. Tab 7: Contains various operation buttons for robot control, editor, and 3D simulation functions. 

8. Tab 8: Primarily consists of drop-down menus, which display corresponding function lists based on 
the selected item in the menu. It includes functions such as manual control, IO, 3D display, starting 
the Teach Pendant, and other 3D operations. 

3. Functions of Project Management 
When opening the EditorP software, all locally existing programs will be listed. 
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The function pages are shown in the following image: 

 

 

After connecting to the controller, the programs on the controller will also be listed, as shown in the 
image below: 

 

 

1. Workspace expansion 
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2. Right-click menu functions of the Workspace, as shown below: 

 

3. Right-click menu functions of the Project, as shown below: 
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4. Right-click menu functions of the Program, as shown below: 

 

5. Double-clicking on a node (global variable, system variable, project variable, program, program 
variable, other nodes not supported) will display it in a tab, as shown in the image below: 
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If it is a graphical function, the program will display a graphical interface. 

 

For the right-click menu of global variables, system variables, project variables and program 
files, it will be opened using the Windows self-contained program, as shown in the image below: 

 

 



 

 
 

1  

 

 

 

 

3.1. Differentiate Icons in Project Management 
1. Text files and graphical labels are distinguished by an icon. 

 

3.2. Global Project 
Each workspace has a unique global project named "GlobalProg". It cannot be deleted, renamed, or 
copied. It does not have project variables and supports the following operations. These operations are 
the same as regular projects, and all other projects within the workspace can use its programs. 
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3.3. Create a New Workspace 
Click the "+" button to create a new graphical workspace by default. After removing the checkmark, 
you can choose to create a text project or a graphical project using templates. The default creation for 
programs is a "graphical workspace". 

 

3.3.1. Create a New Text Workspace 
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3.3.2.  Create Text and Graphical Workspaces Based on Templates 

Create the graphical workspace 

 

 
Create the text, as shown below 
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3.4. Right-Click Menu on the Project Tree 

3.4.1. Workspace 

Local workspace supports the following operations: 

 
Server workspace supports the following operations: 
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3.4.2. Project 

     

3.4.3. Program 
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3.4.4. Variable File 
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3.5. Variable Module 
The variable module includes system variables, global variables, project variables, and program 
variables. These system variables cannot be edited, and each variable type has its own set of 
permissible variable creations. 

3.5.1. System Variables 

System variables cannot be edited, but can only be viewed. Double-clicking on the system 
variable node in any workspace opens it. Programs throughout the workspace can use these 
variables, as shown in figure below:  
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3.5.2. Global Variables 

Global variables encompass all variable types, support adding, modifying, copying, and deleting 
functions. Programs throughout the workspace can use these variables. 
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3.5.3. Project Variables 

Some variables can be added, but only programs within the current project can use them. 
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3.5.4. Program Variables 

Only the current program can use these variables. 

 

3.5.5. View, Modify and Save Variables 

After opening or creating a workspace, double click on the corresponding variable node icon in the 
resource tree to open the UI page for that variable file on the right side. 
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3.5.6. Create/Delete/Copy Variables 

Variable Creation, Copying and Deletion 

 

Rename variables 
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3.5.7. Rename Variables 

To rename a variable, select the variable in the table, edit its name, and click "Save". 
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3.5.8. Variable Comments  

 

To add comments to a variable, select the variable in the table and enter the comments in the 
"Variable Comment" section on the right. Click "Save" to save the comments. The comments will be 
visible when the project is opened. 

3.5.9. Modify Variable Attribute Values 

Click on a variable row in the table, and its current attribute values will be displayed on the 
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right-hand side. Modify the desired attributes in the "Attribute" page. After making the modifications, 
click the "Save" button to update the variable table with the new attribute values, as shown in figure 
below. Please note that clicking the "Save" button is necessary for the changes to take effect.  

 

3.6. Program Editing 
Users can conveniently edit and modify programs using this software. The program editing UI is 

displayed as follows: 
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1. Double-clicking on a program node in the project tree opens the corresponding program for editing. 

2. The program editing area provides flexible and convenient text programming editing operations. 
Common text shortcuts are supported, such as Ctrl+C for copy, Ctrl+X for cut, Ctrl+V for paste, 
Ctrl+Z for undo, and Ctrl+Y for redo. Users can also use the toolbar in the program editing UI to 
perform corresponding operations. 

3. Program commands and keywords are highlighted for easy visibility. 

4. Auto-suggestion functionality is available for code input (variables, commands, etc.) within the 
project scope. Tips are displayed to guide users in selecting the desired input options. 

  

5. When entering parameters for command functions and typing a left parenthesis, a parameter input 
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prompt will appear along with an automatically filtered selection list for the current input. Each time 
a comma is entered for parameter input, the prompt list for the current command parameters is 
updated, and the corresponding parameter in the function prompt box is highlighted to assist users 
in inputting the correct values. 

 

6. For commands with multiple parameter combinations, such as movJ, movL, etc., various optional 
and mandatory parameters are included (although optional, the order of parameters for each 
parameter type is dependent). After entering each parameter, the editor updates the input prompt 
list for the available parameters and highlights all currently available parameters in the function 
prompt window. This approach efficiently guides users in editing commands with such parameter 
combinations. 

 

On the PC software interface, there is a difference in how variables are displayed compared to the 
teach pendant programming UI. For example, when selecting a variable from the input prompt box and 
entering it in the editor, it should be displayed in the form of s:, p:, g:, or l: as a prefix. s: represents 
system variables, p: represents project variables, g: represents global variables, and l: represents 
program variables. To facilitate the filtering of variables from different domains, users can manually 
input s:, p:, g:, or l: to automatically update the input prompt box and display variables from the 
corresponding domain for selection. 
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7. The program editor can provide real-time error detection and display basic error messages while 
the user is typing. Error information is displayed in the compilation and debugging area below or 
highlighted in red on the error line for easy identification. 

 

 

 

8. Once the editing is complete, clicking the  icon allows for the compilation and saving of 

the currently edited program. At this point, syntax errors are also checked. If any errors are 
displayed, the save operation will not be successful, and the user needs to make the necessary 
program modifications as prompted. After verifying that there are no errors, the program can be 
successfully compiled and saved.  

9. Code comments can be added in the editing area using either "//   " or "/* */". 
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3.7. Command Navigation 
By clicking the button as shown in the following image, the command navigation window is 

opened. 
 

 
Double-clicking on the nodes in the expanded command list will display the corresponding 

commands. Moving the cursor to the desired position in the editing area and double-clicking on the 
command will quickly add it to the program. 
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3.8. Display of Running Program 
During single-step or continuous program execution, the currently running program line is 

highlighted. 

 

 

The virtual teach pendant can be opened during program execution to synchronize and compare 
the displayed pointer line for any differences. 

 

3.9. Program Saving  
1. Click the icon in the toolbar to save the modified program locally. 
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3.10. Workspace, Project and Program Upload/Download 
 
This functionality requires a connection to the controller. Local programs can be downloaded to the 
controller, and controller programs can be uploaded to the local environment. It is also possible to 
selectively upload or download a node from the workspace tree. When clicking on a node in an 
independent workspace, it is important to ensure that the workspace exists either locally or on the 
controller; otherwise, an error will occur. 

3.10.1. Download 

Select the local "text" -> click the "Download" button. 

 

3.10.2. Upload 

Select the "GlobalProg" on the server -> Upload. 
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If there are differences between the local and controller versions, a prompt will appear, allowing the 
user to decide whether to overwrite the controllers file.  
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3.10.3. Upload/Download Error Messages 

If an independent unit under the workspace is selected for upload/download and the workspace does 
not exist locally or on the controller, the following error will be reported. 

 

1. Download: If the workspace where the project resides does not exist on the server, 
the following error will be reported. 

 

2. Upload: If a project is selected from any workspace on the server, right-clicked, and 
then uploaded, and the corresponding workspace does not exist locally, the upload 
will fail, as shown in the following image. 
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4. Auxiliary Program Functions 
Each tab represents a specific function and includes the following functionalities: 

 

4.1. System Output 
It primarily displays controller information and outputs user operations, such as connecting to the 
controller. 
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4.2. Error Messages 
This feature provides error notifications during program development. 

 

Double-clicking on an error will navigate to the corresponding error line in the text. For example, 
double-clicking on a specific line in the "Error Messages" will jump to the corresponding error line. 
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4.3. Bookmarks 
Used to add bookmarks in the program for easy reference and navigation. When a line in the program 
is double-clicked at its beginning position, a bookmark indicator will appear as shown below, indicating 
the successful addition of a bookmark. 
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Double-clicking on a line in the bookmark bar can also jump to the specified line in the text. 
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To remove a bookmark, simply double-click on the small tag associated with it. 
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4.4. Variable Monitoring 
In a text program, selecting a variable and right-clicking on it allows the user to choose "Add 
Monitoring" to add the variable to the monitoring list. 

 
Successful addition is displayed as follows: 

 

4.5. Program List 
This feature displays the programs being called in real-time during program execution. 
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4.6. Search Results 
This feature is primarily used for searching within the workspace and projects in the project 
management tree. It supports case-sensitive and whole-word matching, but does not support regular 
expressions. 

4.6.1.  Searching within the Workspace 

 

 
Search results 



 

 
 

4  

 

4.6.2. Searching within a Project 

Functionality similar to 4.6.1. 

 

4.6.3. Searching within Text 

Opening a text editor and using the shortcut Ctrl+F brings up the search box as shown below. 



 

 
 

4  

 
Search location options include: current document, project of the document, and workspace of the 
document. 

 
Search results are displayed under the "Search Results" tab. 
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5. Graphical Programming 

5.1. Create a Graphical Project 
Refer to Section 3.3 for creating a graphical workspace. 
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5.2. Introduction to Graphical Blocks 

5.2.1. Command Blocks 

Each command is represented by a graphical block that can be dragged out to implement its 
functionality independently. 

 
 
When a block is dragged out, only the required parameters are displayed, and non-required 
parameters are collapsed by default. Users can expand to select the required parameters, as shown in 
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the example. 

 
Each input is filtered based on the variable type required. 

 
If the desired parameters are not available, users can click the "+" button to add variables. By selecting 
the desired variable type, they will be directed to the corresponding file to add the required type. 

 
Special blocks for certain commands are displayed as shown below: 

 
The following is an example of a block that can be concatenated: 
 



 

 
 

4  
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5.2.2. Assignment and Variable Blocks 

1. Variable Block 
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The Set/Assignment Block is primarily used to assign values to variables. 

 

In the Assignment Block, you can select one variable to assign its value to another variable. 
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There are three concatenation blocks for String, Boolean, and Numeric types. 

 

5.3. Simple Demo Program Demonstration 
1. Create a new graphical workspace. 

Please refer to Section 3.4 for the steps to create a new graphical workspace. Below is an 
example of a newly created demo. 

 
2. Double-click to open "NewProgram" 
By default, it has a "Start" and an "End" block. 
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3. Click on the command tree on the left side and select any command. For example, lets choose 

the "Motion" command. Drag and drop a graphical block between "Start" and "End". 
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Select a block for linear motion, as shown in the image. 

 

 
4. For the "Target Position" dropdown in the block above, select a parameter variable. 
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If there are no variables in the dropdown, you need to add a new variable. 

 
5. Click the "+" button to add a new variable. 

 
For example, if you select "Program Variable", it will take you to the program variables file where 
you can add a new "Target Position" variable. 
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Once you add the variable, it will appear in the dropdown list when you click on the "Target 
Position", as shown in the figure below. 

 
After selecting a variable, it will be displayed as shown in the figure. 
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If you select the wrong variable, you can click the "x" clear button in the dropdown to remove the 
selection and choose another variable. 

 

After making the new selection, it will be displayed as shown in the figure. 
 

 
6. Click "Save" to save the graphical program. 

In this manner, he graphical project is edited and completed. Similar steps can be followed for 
other commands as well. 
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7. A simple Demo graphical program 

Graphical Program Implementation: 

 
Text Program Implementation: 
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5.4.  GUI Interface 
The GUI interface is a tool provided to users for designing a customized interface according to their 
needs. It helps users display the programs status, control the robots start /stop operations, and switch 
program runtime parameters efficiently. 
1. Create a graphical project using the "demo_gui" template: 

 
2. Open the newly created graphical program and click on "Design GUI Interface". 
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3. In the opened GUI interface, click on "Initialize Parameters". Initializing parameters involves 

extracting the basic variables used in the program and placing them within this GUI module. 
4. Drag and drop the corresponding components onto the canvas based on your requirements. Lets 

take the " Stateful Component" as an example. Drag and drop a stateful component onto the 
canvas. 
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5. Clicking on the stateful component on the canvas will open a properties panel, as shown in the 

figure. 
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When you need to highlight a specific status, drag the "Send Data to GUI Component" block into 
the program, as shown in the figure. 

 
Here, "dinrrya30h" is the GUI components ID selected from the dropdown, and "Pl ace" is the 
string sent to this component. 

6. Click the "Save" button in the top left corner to save the designed GUI interface. 
7. Launch the program and open the GUI interface to observe the changes in the stateful 

component. 
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6. Settings 

6.1. Zero Calibration 
If the robot loses its zero point and cannot return to the correct position, you can perform zero 
calibration to obtain the zero point. 
 
Open the calibration page 
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Axis jogging 

 
Set the zero point 
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Zero calibration 

 
Complete the zero calibration process. 

6.2. Communication Verification 
This feature is used to verify the hardware environment of the communication channel. You can 
access the communication verification page as shown in the image: 
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6.2.1. Socket Communication Verification 

Select the socket communication type and fill in the IP address, port number, and the content to 
be sent. Clicking "Send" will send the data to the server, and if the receiving window receives the 
data, it indicates that the communication is working correctly and can be used for sending and 
receiving communication with the remote end. 
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6.3. Basic Settings 

 
Set default parameters for the robot. 

6.4. Tool Coordinate System Calibration 
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6.5. User Coordinate System Calibration 
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6.6. Vibration Suppression 

 
 

7. Manual Control 
To enter the Manual Control page, follow the steps: Menu bar - Function - Manual Control. This 
will take you to the Manual Control page. 
Note: The Manual Control page is only available for robot models with suffixes -SR, -MI, -MI/. 
Other models cannot access this page. 
Refer to the following figure: 
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7.1. Coordinate Display 
The left side displays the robots world coordinates, and the right side displays the robots joint 
coordinates. 
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7.2. Manual Control 
The two columns of buttons control the positive and negative movements of each axis. 

 

7.3. One-click Motion 
1. Select a waypoint from a variable file. 
2. Adjust the waypoint data if necessary. 
3. Choose the motion mode: Linear or Joint. 
4. Choose the motion direction: Forward Upward Tilt, Forward Downward Tilt, Backward Upward 
Tilt, Backward Downward Tilt, etc. 
5. Save the modified data back to the selected waypoint. 
6. Click on One-click Motion to move the robot to the specified waypoint using the configured 
settings. 
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7.4. Manual Motion Parameter Settings 
1. Select the object to be configured: Local or External Axes. 
2. Set the tool coordinate system, which is the tool coordinate system of the currently loaded 
project in the controller. 
3. Set the user coordinate system, which is the user coordinate system of the currently loaded 
project in the controller. 
4. Set the jog mode: Jogging or Continuous. 
5. Set the motion mode: Axis Coordinates (Joint Motion) or World Coordinates (Path Motion). 
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8. IO Function 
Click on "Function" in the menu bar and select "IO" to enter the IO Detection page. 

Refer to the following figure. The IO-related data is transmitted from the main interface. 

 

8.1. Digital  
Upon entering the IO Detection page, the default view is the "Digital IO" list, where you can check 

the status of the IOs. 

Users can view the IO status on the control module: Green indicates a signal, and gray indicates 
no signal. 
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D1-D8: Not allowed for output. Double-clicking on D1-D8 will display the following: 

 

 
Users can check the actual IO status on this page. 

8.2. Analog  
Users can check the actual analog status on this page. 

 
 

8.3. Virtual Digital  
Users can check the status of virtual IOs on this page. 
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8.4. Virtual Analog  
Users can check the status of virtual analog IOs on this page. 

 

 

8.5. Custom IO 
   All signals can be assigned labels. Users can select Digital IO, Analog IO, Virtual Digital IO, or 
Virtual Analog IO and add them to Custom IO. 
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Implementing Custom IO: Select an IO, right-click, and choose "Add to Custom". 
 

 
 
The added IO can be seen in the definition. 

 
In Custom IO, you can also delete individual IOs or remove all added IOs. 
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9. 3D Function 
The 3D simulation includes the 3D menu, toolbar, property window, scene tree, and 

simulation window. 

Left-click to rotate the scene, middle-click to pan the scene, and scroll the mouse 
wheel to zoom in or out. 

 

9.1. Open the 3D Simulation Window 
 

Click on "Open 3D Window" to load the 3D simulation window. 
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Note: The window data in the top right corner shows the robots world coordinate system, 
which is the data relative to the center point of the robots base surface.  

Click on "Collision Detection" to open the collision detection point list window. Further details on 
the collision detection module will be explained later. 

 

9.2. "File" Menu 
Click on the "File" option in the 3D menu to display the "File" menu. 



 

 
 

8  

 

9.2.1. Create Scene (CTRL+N) 

Prerequisite: If you only want to view the motion of a single robot without any scene, there is no 
need to create a new scene. However, if you want to include other models, you need to create a new 
scene. 

Shortcut key (CTRL+O). 

Click on the 3D menu -> Click on File -> Click on Create Scene to create a new scene, which 
includes creating a scene space and a scene file. 
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Alternatively, right-click on an empty space in the 3D simulation page and choose "Create Scene". 

 

9.2.2. Import Other Models 

Click on the 3D menu -> Click on File -> Click on Import Other Models to import models other than 
the robot model and robot tool model. 

 

Alternatively, right-click on an empty space in the 3D simulation page and choose "Import Other 
Models". 
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Note: Currently, the supported model format is .stl format. Please ensure that the size does not 
exceed 150MB. If the size exceeds 150MB, it may affect the smoothness of the display. 

9.2.3. Import End Effector Tool Model 

Click on the 3D menu -> Click on File -> Click on End Effector Tool Model to import the model of 
the robots tool.  
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Note: Currently, the supported model format is .stl format. Please ensure that the size does not 
exceed 150MB. If the size exceeds 150MB, it may affect the smoothness of the display. 

9.2.4. Save Scene (CTRL+S) 

Click on the 3D menu -> Click on File -> Click on Save Scene to save the current scene. 

Shortcut key (CTRL+S). 
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9.2.5. Open Scene (CTRL+O) 

Click on the 3D menu -> Click on File -> Click on Open Scene to open a 3D scene file. 

Shortcut key (CTRL+O). 

 

 

Alternatively, right-click on an empty space in the 3D simulation page and choose "Open Scene". 
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9.2.6. Save Scene As 

Click on the 3D menu -> Click on File -> Click on Save Scene As to save the scene workspace 
files to a different folder. 
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9.2.7. Close Scene 

Click on the 3D menu -> Click on File -> Click on Close Scene to close the currently opened 
scene. 
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9.3. "Accessibility" Menu 

9.3.1. Capture Screen 

Click on the 3D menu -> Click on Accessibility -> Click on Capture Screen to save a screenshot of 
the current simulation page. 

 

 

9.3.2. Record Screen 

Click on the 3D menu -> Click on Accessibility -> Click on Record Screen to record a video of the 
current simulation page. 
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9.3.3. Stop Recording 

Click on the 3D menu -> Click on Accessibility -> Click on Stop Recording to stop the current 
screen recording of the simulation page. 

 

9.3.4. Unit Model Movement (ALT+1,2,3,4,5,6,7) 

Click on the 3D menu -> Click on Accessibility -> Click on Unit Model Movement -> Choose 
XYZABC axis to move the model. 

1. Select X-axis: Corresponds to the translation axis X of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the X-axis, and 
press the DOWN arrow key to decrease the value of the X-axis. 

Shortcut key (ALT+1) 
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The default unit value added is 1, and you can set the unit movement length in the options. 
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2. Select Y-axis: Corresponds to the translation axis Y of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the Y-axis, and 
press the DOWN arrow key to decrease the value of the Y-axis. 

Shortcut key (ALT+2) 

 

3. Select Z-axis: Corresponds to the translation axis Z of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the Z-axis, and 
press the DOWN arrow key to decrease the value of the Z-axis. 

Shortcut key (ALT+3) 
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4. Select A-axis: Corresponds to the rotation axis A of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the A-axis, and 
press the DOWN arrow key to decrease the value of the A-axis. 

Shortcut key (ALT+4) 

 

5. Select B-axis: Corresponds to the rotation axis B of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the B-axis, and 
press the DOWN arrow key to decrease the value of the B-axis. 

Shortcut key (ALT+5) 

 

6. Select C-axis: Corresponds to the rotation axis C of the model. After selection, there will be text 
prompts in the scene. Press the UP arrow key on the keyboard to increase the value of the C-axis, and 
press the DOWN arrow key to decrease the value of the C-axis. 

Shortcut key (ALT+6) 



 

 
 

9  

 

7. Select "No Movement" axis: Cancel the movement axis of the model. 

Shortcut key (ALT+7) 

 

8. Click on "Increase Text Size": Enlarges the text of the models movement axis.  

Shortcut key (ALT+E) 

 

9. Select "Decrease Text Size": Reduces the text size of the models movement axis.  

Shortcut key (ALT+R) 
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9.3.5. Select Slider Axis 

Click on the 3D menu -> Click on Accessibility -> Click on Slider Axis. 

Selecting the X-axis means that both the slider and the slider robot will move in the X-axis direction of 
the simulation world coordinate system. 

 

Selecting the Y-axis means that both the slider and the slider robot will move in the Y-axis direction of 
the simulation world coordinate system. 

 

9.3.6.  Zoom In Base Coordinates (Page Up) 

Click on the 3D menu -> Click on Accessibility -> Click on Zoom In Base Coordinates to zoom in 
on the base coordinates of the current model. 

Shortcut key (Page Up) 
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9.3.7. Zoom Out Base Coordinates (Page Down) 

Click on the 3D menu -> Click on Accessibility -> Click on Zoom Out Base Coordinates to zoom 
out of the base coordinates of the current model. 

Shortcut key (Page Down) 
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9.3.8. Options 

 
Click on the 3D menu -> Click on Accessibility -> Click on Options to open the options settings 

window. 

 

First item: Set simulation background color and text color in the data window. 
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Second item: Open the folder for saving screenshots and recorded screens. 

 

Third item: Set the value for unit movement of the model. 

 

Fourth item: Recent file paths. 
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    Manage the recently opened file paths. Click  to delete a file path record, 

and click  to open the folder of this path. 

Fifth item: Collision Detection 

Set this parameter to adjust the time interval for collecting collision points in collision 
detection. 

 

Sixth item: Button Continuous Movement Speed 

Set the speed of robot movement controlled by buttons. The greater the number, the 
faster the speed. 
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Seventh item: Dragging Model 

Set the speed of dragging the model and the size of the coordinate system for 
dragging the model. 
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9.4. Toolbar 

9.4.1. Front View 

To set the front view of simulation window. 

 

 

9.4.2. Rear View 

To set the rear view of simulation window. 
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9.4.3. Left View 

To set the left view of simulation window. 
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9.4.4. Right View 

To set the right view of simulation window. 
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9.4.5. Top View 

To set the top view of simulation window. 
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9.4.6. Bottom View 

To set the bottom view of simulation window. 
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9.4.7. Restore View 

To set the restore view of simulation window. 

 

 

9.4.8. Path 

To set the path of simulation window. 
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Note: This path is relative to the center point of the robot base. Therefore, in the case 
of a 7th-axis slider simulation, the displayed path is only for the robot and does not include 
the path of the slider. 

9.4.9. Always On Top 

To set the simulation window to be always on top. 

 

9.4.10. Modes 

Opens or closes the scene tree and property window in the simulation window. 
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9.4.11. Clear 

Clears the display of all selected variables in the 3D simulation of the current project. Currently, 
the variables that can be displayed in 3D include position variables: axis coordinates (APOS) and 
Cartesian coordinates (CPOS), area variables (AEAR), user coordinates (USERCOOR), and tool 
center point coordinates (TOOL). 

 

Example: After selecting variables in the project, they are displayed in the 3D simulation.  
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Clicking the Clear button will remove all variables that are currently displayed in the 3D simulation. 

 

 

9.4.12. Drag 

The dragging mode is displayed at the end current robots tool coordinate system, 
allowing you to perform virtual robot axis dragging movements. 

First, set the project as the current project: Right-click on the project name and select 
"Set as Current Project Space". 
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In the Property Window, select the current tool coordinate system. 

 

 

Click on "Drag". 
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A dragging model will appear at the end of the robots tool. Place the mouse over the 
corresponding axis and drag it along the axis. 

 

9.4.13. One-Click Fixing 

   Fixes the 3D simulation window in the split-screen position. After opening the 3D window, click on 
"Always On Top" first, and then click on "One-Click Fixing." 
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9.4.14. Model Dragging 
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   After selecting a model, click on the "Drag Model" button. A coordinate system will appear, and you 
can manually move the model by dragging the coordinate system. 

 
 

9.5. Property Window 

9.5.1. Model Name 

To display current models name.  

 

 

 

9.5.2. Set Current Reference Coordinate System 

When in the selection point mode, the coordinate data of the simulation points will change 
according to the data of the reference coordinate system. Here, you can set the reference coordinate 
system. 
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9.5.3. Set Current Robot Tool Coordinate System 

    To select the current virtual robots end -of-arm tool coordinate system. 

 

9.5.4. Set Model Posture 

To set the current models pos ture in the current simulation scene. 

 

9.5.5. Set Model Display and Hide 

To set the visibility of the model in the simulation page. 
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(Show Model)                            (Hide Model)  

9.5.6. Set Base Coordinate System Display and Hide 

To set the visibility of the models base coordinate system in the simulation page.  

 

(Show Base Coordinate System)          (Hide Base Coordinate System) 

 

9.5.7. Set Model Color 

To set the models color. Click on the Color button and select a color. 
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9.5.8. Set Robot Flange Coordinate System Display and Hide 

To set the visibility of the robots flange coordinate system in the simulation page.  
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(Show Current Tool Coordinate System)          (Hide Current Tool Coordinate 
System) 

9.5.9. Set Robot Tool Coordinate System Display and Hide 

To set the visibility of the robots t ool coordinate system in the simulation page. 

 

(Show Current Tool Coordinate System)        (Hide Current Tool Coordinate System) 

9.5.10. Copy Model Posture 

To copy the posture data of the current model. 
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9.5.11. Paste Model Posture 

To paste the copied pose data to the current model. 

 

9.5.12. Select Virtual Robot Motion Reference Coordinate System 

To specify the coordinate system that the virtual robot uses as a reference for motion. The default 
initialization is the axis coordinate system. 
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9.5.13. Display Current "mode" Value of Virtual Robot 

 

9.5.14. Single Axis Control of Virtual Robot 

Depending on the selected coordinate system, the axis control buttons will switch to control 
different axes. The initial setting is the axis coordinate system, and the axis control allows continuous 
movement. 
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9.6. Scene Tree 

9.6.1. Model List 

To list the models in the scene. The model name is on the left, and the control for showing or 
hiding the model is on the right. 

 

 

The first row of "Models" controls the visibility of all models in the current scene. 

 

9.6.2. Right-Click on "Models" to Open the Current Scene Space 

Folder 

Right-click on "Models" to open the current scene space folder. 
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"Options" Menu: Clicking on "Options" opens the settings window for the 3D simulation. The tools 
in this menu are the same as the ones in the other menu bars and the "File" menu in Section 8.2. 
Right-clicking here is for convenience.  

9.6.3. Right-Click Menu for Scene Tree Model Item 

Right-clicking on a model item in the scene tree opens a menu. If the model is a robot, the menu 
options are the same as those in "8.7.4. Right-Click Robot Model Menu". For specific details, refer to 
"8.7.4. Right-Click Robot Model Menu". 

 

If the model is a regular model, a menu will pop up with options. The functionality of the menu 
options with the same names as in "8.7.5. Right-Click Model Menu" is the same. For specific details, 
refer to "8.7.5. Right-Click Model Menu".  
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If the model is a robot end-of-arm tool model, a menu will pop up with options. The functionality of 
the menu options with the same names as in "8.7.6. Right-Click Tool Model Menu" is the same. For 
specific details, refer to "8.7.6. Right-Click Tool Model Menu". 

 

9.7. Simulation Window 

9.7.1. Simulation Window 
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   The  at bottom-left corner represents the pose of the world coordinate system. 

 

9.7.2. Robot Data Window 

 

9.7.3. Right-Click Menu for Simulation Scene Window 

9.7.3.1 Recently Opened Scene Files Menu 

Records the recently opened scene files for quick selection. 
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9.7.3.2 Collision Detection 

 

9.7.3.2.1 Select Object Collision Sets 

To select the object collision sets, which are the models to be included in the collision 
detection. When clicking this option, a collision set page will appear as shown in the figure. 
The collision sets are divided into object collision sets and robot tool collision sets. The 
object collision sets include regular models that need to participate in collision detection, 
excluding the models related to the robot. The robot tool collision sets include the tool 
models that the robot needs to participate in collision detection. 

 
To select models for collision detection, simply click on them. When selecting regular 



 

 
 

1  

models, they will appear in orange-red color, and when selecting tool models, they will 
appear in dark blue. 

 
Additionally, joint models on the robot (such as pallet models or other balance bar 

models, which are not currently included in collision detection) are automatically included 
in the collision detection. 

 
The top half of the collision set page displays the names of the currently selected 

models for collision detection and their display status.  
The bottom half is used for collecting collision points after activating the "Start 

Collision Detection" function, enabling the collection of collision points at regular intervals. 
By clicking on the collected collision points, it is possible to quickly navigate the virtual 
robot and examine the collision situation. 

9.7.3.2.2 Start Collision Detection (Without Recording Collision Points) 

Clicking this function starts the collision detection thread, which performs collision 
detection on the models in the collision set. During the movement of the virtual robot, if 
there is a collision with any model in the collision set, the model will turn red as shown in 
the figure. To activate the "Start Collision Detection" function, you need to click on the 
"Stop Collision Detection" function. 

 

9.7.3.2.3 Start Collision Detection 

Clicking this function starts the collision detection thread, which performs collision 
detection on the models in the collision set. During the movement of the virtual robot, if 
there is a collision with any model in the collision set, the model will turn red. Additionally, 
while moving the robot, the system will periodically check and record collision points at 
the locations of collisions, as shown in the figure. 
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By clicking on the recorded collision points on the collision detection page, it is 

possible to quickly move the robot to the collision points and examine the collision 
detection situation. 

 

9.7.3.2.4 Stop Collision Detection 

     Stops the collision detection thread. 
 

9.7.3.2.5 Display Collision Detection Set Window 

     If the collision detection set window is closed, clicking this function will reopen the 
selected model collision set. 
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9.7.3.3 Settings 

 
  Display Reference Coordinate System: Clicking this function will show or hide the 
reference coordinate system model. 

 
(Show Reference Coordinate System)        (Hide Reference Coordinate System) 

 
   Grid Display: Clicking this function will show or hide the grid. 
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(Grid Display)                             (Hide Grid) 

 
The functionality of opening and closing scenes is the same as the corresponding 

tools in the "File" menu in section 8.2. Please refer to the functionality of the 
corresponding tools in the "File" menu in section 8.2. This is provided for ease of use. 

9.7.3.4 Reload Connected Robot 

This function is used when, in the connected state, clicking on close scene will also close the robot 
model. If you want to display the current robot model again without switching to another robot model, 
you can click this function. 

 

9.7.3.5 Select Point Mode 

Enables the selection of model vertices to quickly create vertices on the model, making it 
convenient to move the robot end-of-arm tool to that vertex for adjustment of point data. When 
selecting point mode, you need to click on the model to be selected, then right-click on the model and 
select the "Reset Center Point" function. Then zoom in on the model and select the vertices of the 
model. When the color of the mouses sphere turns red, it means that the point is a vertex of the model. 
Use CTRL + left-click to create a simulation point for the model vertex.  
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 (Select Model Vertex) 

 

 
 (Create Simulation Point for Model Vertex) 

9.7.3.6 Display Select Point Window 

Clicking this function opens the select point page, which records the selected simulation points or 
the midpoints and centers created based on simulation points. Please refer to section 8.9 for 
information on how to create simulation points.  
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9.7.3.7 Information Output Window 

   Clicking this function opens or closes the information output window. This is used to view 
debugging, warning, or alarm information in the 3D simulation.  

 
 

 

9.7.3.8 Options 

Clicking this function opens the options window. 
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9.7.4. Right-Click Robot Model Menu 

Right-clicking on the model will bring up a menu that allows you to set the models properties.  

 

9.7.4.1 Robot Model Name 

Displays only the name, no effect if clicking. 
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9.7.4.2 Select Robot Model on Slider 

Clicking this option allows you to select the robot model on the slider. 
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9.7.4.3 Select X-axis Movement on Slider for the Robot 
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9.7.4.4 Select Y-axis Movement on Slider for the Robot 
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9.7.4.5 Import Robot End-of-Arm Tool Model 
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9.7.4.6 Show Robot Model 

 

9.7.4.7 Select Robot Base Coordinate System 
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9.7.4.8 Select Robot Model Color 

 

9.7.4.9 Reset Center Point 

  To set the rotation and zoom center position of the scene to the location clicked by 
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the mouse. This position is initially set to the center position (0,0,0) of the world coordinate 
system. 

 

9.7.4.10 Select Point Mode 

  Enabling this mode allows you to select vertices on models other than the robot 
model. When the mouse moves over the vertices of a model, the color of the current 
mouse sphere turns red. Use CTRL + left-click to create a simulation point relative to the 
reference coordinate system at the vertex position on the model. The default reference 
coordinate system is the world coordinate system. 

 

The reference coordinate system can be set to the world coordinate system, robot 
coordinate system, or other user-defined coordinate systems. 

Creating simulation points allows you to quickly move the robot end tool to that 
simulation point or create CPOS variable points. 

Note: The robot will move to the simulation point with the current posture. Similarly, 
when creating a CPOS variable point, it is based on the XYZ values of that simulation 
point and the robots current posture values. If there is a requirement for posture, the 
robot needs to be moved to that point, and then the robots posture values should be 
adjusted for teaching. 
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9.7.4.11 Select Drag Mode 

  Enabling this mode will display the drag model under the current tool coordinate 
system variable of the robot. It includes XYZABC six-axis models. When you click and 
drag this model on the robot, it represents single-axis movement of the robot based on the 
tool coordinate system as the reference coordinate system. 
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9.7.4.12 Create Tool End Simulation Point 

  Using the robot coordinate system as the reference coordinate system and under 
the current tool variable of the robot, you can create simulation points for the robots 
end-of-arm tool variable. This is used to record points that may be needed or to quickly 
move the robot between such points. 
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9.7.4.13 Copy Posture 

The copy posture and paste posture functions are used together. Clicking this 
function will copy the posture data of the current model. 
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9.7.4.14 Paste Posture 

  Pasting the posture copies the saved pose data of another model and pastes it into 
the target model to apply it, allowing for quick placement of models and scene setup. 
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9.7.5. Right-Click General Model Menu 

 

9.7.5.1 Model Name 

The first column in the menu displays the model name. 
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9.7.5.2 Delete Model 

Clicking this function will delete the model. 

 

9.7.5.3 Select Slider 

Click this function to set the model as a slider model. It is used for setting up the seventh-axis 
ground track model. 

 

 

9.7.5.4 Select X-axis Slide Direction 

By clicking on this function, the motion direction of the rail model, which has already been 
configured, can be set to either the X-axis or the Y-axis. 



 

 
 

1  

 

9.7.5.5 Select Y-axis Slide Direction 

By clicking on this function, the motion direction of the rail model, which has already been 
configured, can be set to either the X-axis or the Y-axis. 

 

9.7.5.6 Show Model 

Clicking this function will show or hide the model. 

 

9.7.5.7 Show Base Coordinate System 

Clicking this function will show or hide the base coordinate system of the model. 
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9.7.5.8 Select Model Color 

Clicking this function allows you to set the color of the model. 

 

9.7.5.9 Reset Center Point 

Clicking this function allows you to set the current mouse position as the center point for rotation 
and zooming. 

 

9.7.5.10 Copy Posture 

Clicking on this function allows the current posture data of the model to be copied. 
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9.7.5.11 Paste Posture 

Clicking on this function allows the current posture data to be pasted onto the current model, 
enabling quick placement of the model. 

 

 

9.7.6.  Right-click on the Tool Model Menu 
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9.7.6.1 Model Name 

The first column of the menu displays the model name. 
 

9.7.6.2 Delete Model 

Clicking on this function deletes the model. 
 

9.7.6.3 Show Model 

Clicking on this function shows or hides the model. 
 

9.7.6.4 Show Base Coordinate System 

Clicking on this function shows or hides the base coordinate system of the model. 
 

9.7.6.5 Select Model Color 

Clicking on this function allows setting the model color. 
 

9.7.6.6 Reset Center Point 

Clicking on this function sets the current mouse position as the center point for rotation, zooming 
in, and zooming out. 

 

9.7.7.  Right-click on the Point Model Menu 

When right-clicking on the point model, a menu will pop up. 

 

9.7.7.1 Delete Selected Point 

Clicking on this function deletes the current simulation point. 
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9.7.7.2 Move Robot to Selected Point 

Clicking on this function quickly moves the robots current tool coordinate system end position to 
that point. The posture data is the current robots posture data. The robot may not be able to move to 
any position, depending on whether the points data is within the robots inverse  solution range. 

9.7.7.3 Copy Posture  

Clicking on this function copies the posture data of this point. 
 

 

9.8. External Axis (Ground Track Axis) Simulation 

9.8.1. Configure the robots config file  

 

9.8.2. Build the scene 

1. Create a new scene. 

2. Select the robot model. 

3. Import the slider and rail base models. 

Note: The world origin coordinate system for the SolidWorks base and slider models should be set 
to the bottom-left corner. 
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4. Obtain the coordinates of the slider relative to the base origin using SolidWorks. 

 

5. Obtain the coordinates of the center point of the robot base surface relative to the slider base 
origin using SolidWorks. 

 

6. Manually record the data in a text file and input the data into the corresponding models po sture. 
Set the translation direction for the slider and rail robot. 
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9.8.3. Run the program to observe the simulation effect 

 

9.9. Create Simulation Points 

9.9.1. Create Arbitrary Simulation Points for Models 

  Move the mouse over the model to the desired position for creating a new simulation point, then 
press CTRL + left-click to create an arbitrary simulation point. 

Arbitrary simulation points are displayed in blue color as shown in the figure. 

 

9.9.2.  Create Vertex Simulation Points for Models 

  Tight-click on the blank area of the simulation window to open the menu, select "Select Point Mode", 
and enable it. Click on the desired model, then right-click on the model to open the menu and select 
"Reset Center Point". The mouse pointer and the text will turn red, indicating the models ver tex. Press 
CTRL + left-click to create a vertex simulation point. After using the point selection mode, click on 
"Select Point Mode " again to disable it for smooth 3D simulation operation. 
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9.9.3.  Select Point Window 

In the blank area of the simulation window, right-click and select "Show Selected Point 
Window" to open the point selection window. 
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In this window, you can manage the created simulation points. 
The Name column displays the name of the simulation point, which is currently not 
editable. 
 

 

The Cartesian Coordinate System Value column displays the values of the simulation 
point, which are currently not editable. 
 

 

The Display column controls the visibility of the simulation point. 

 

Right-clicking on a simulation point opens a context menu. 
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The functionality is consistent with the features described in section 9.7.7. 

 
Press CTRL + left-click to select multiple data points. 

When there are two selected points, a right-click context menu will appear. 

 

You can create a midpoint, a straight line, a linear measurement line (distance between 
two points), or delete the selected simulation points between the two points. 

The midpoint between simulation point 1 and simulation point 2. 
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The center point of simulation points 1, 2, and 6. 

 

The straight line between simulation points 1 and 2. 

 

In the "Select Point Mode," right-clicking on a line allows you to delete the line. 
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The linear measurement line between simulation points 1 and 2. 

 

Right-clicking on the measurement line allows you to delete the line. 
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When there are 3 selected points, a right-click context menu will appear. 

 

You can connect the 3 selected points in the order of selection with a straight line, create 
a center point, or delete the selected point models as a whole. 

 

9.10. Collision Detection 
  For detailed usage of this feature, please refer to section 9.7.3.2. 

9.11. Window Status Bar 
  Displays the current path of the scene file. 
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10. Log Functionality 
The log module records user actions and anomalies, providing relevant prompts to assist users in 

using the software. It also allows users to provide window prompts for troubleshooting purposes and 
seek assistance from professionals to resolve issues. 

10.1. Open Log 
Click on "Tools" -> "Log" to open the log window, where detailed controller messages and local 
operation messages can be viewed. 

 

10.2. Log Path 
The log path can be used to open the local folder and view log messages. 

 

11. Third-Party Programs 

11.1.  Open Machine Vision 
Select "Functions" -> "Machine Vision" to open. 
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11.2. Open Scripting Tool 
Select "Functions" -> "Scripting Tool" to open. 
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12. Software Settings 
This section primarily deals with basic switches and configurations for various functional operations. 
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12.1. System Settings 

 

12.2. Robot Settings 
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12.3. Log 

 
Max File Count: Specifies the maximum number of cached log files. 
Max File Size: To set the maximum memory capacity for a single log file. 
Max Backup File Count: Determines the maximum number of backup files. 
 

13. Annex 

13.1.  View Command Manual  

 

13.2.  Software User Manual 
Select "Help" -> "Software User Manual" to open. 
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13.3. About 
Provides version information about the controller, UI, PLC, kernel, and underlying software being used. 

 
 

13.4. Teach Pendant Permission Allocation 

Function 

√Has Permission × No Permission 
★Confirmed by Secondary 
Password 
Debu
g 

Administ
rator 

User Guest 

Penal 
Keys 

E-stop Key √ √ √ √ 
Mode Switch √ √ √ √ 
Jog Key √ √ √ × 
Interface Switch Key √ √ √ √ 
Function Key √ √ √ √ 

Main 
Interface 

Set Global Speed √ √ √ √ 
Clear Alarms √ √ √ √ 
Switch Multi-Axis √ √ √ √ 
Interface Switch Button √ √ √ √ 

Project 
Managem

Create Project √ √ √ × 
Copy/Paste Project √ √ √ × 
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Function 

√Has Permission × No Permission 
★Confirmed by Secondary 
Password 
Debu
g 

Administ
rator 

User Guest 

ent Delete Project √ √ √ × 
Import/Export Project √ √ √ × 
Load Project √ √ √ √ 
Logout √ √ √ √ 
Open Project √ √ √ √ 
Set Auto Start  √ √ √ × 
Rename Project √ √ √ × 
Refresh √ √ √ √ 

Program 
Editing 

Create Command (Including Quick 
Commands)  

√ √ √ × 

Modify Command (Including Quick 
Commands) 

√ √ √ × 

Set PC Pointer √ √ √ × 
Edit Functions 
(Copy/Paste/Cut/Delete/Comment/F
old)  

√ √ √ × 

Monitor √ √ √ √ 
Refresh √ √ √ √ 
Select Command Line 
(Single/Multiple) 

√ √ √ √ 

Undo √ √ √ × 

Program 
Data 

Create Data √ √ √ × 
Delete Data √ √ √ × 
Modify Data (Including Calibration, 
etc.) 

√ √ √ × 

Refresh √ √ √ √ 
Rename √ √ √ × 

System 
Log 

View Current Alarms √ √ √ √ 
View Historical Alarms  √ √ √ √ 
Get Historical Alarms √ √ √ √ 
Clear Alarms √ √ √ √ 

Manual 
Inspection 

View Joint Coordinate System √ √ √ √ 
View World Coordinate System √ √ √ √ 
View User Coordinate System √ √ √ √ 
View Motor Torque Values √ √ √ √ 
View Single Turn Values √ √ √ √ 
Set Single Turn Values √ √ × × 
Robot Homing √★ √★ √★ × 
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Function 

√Has Permission × No Permission 
★Confirmed by Secondary 
Password 
Debu
g 

Administ
rator 

User Guest 

Tool Switching √ √ √ × 
Coordinate System Switching √ √ √ × 
Jog Mode Switching √ √ √ × 
Jog Coordinate System √ √ √ × 
Jog Settings √ √ √ × 

System 
Settings 

Basic Settings  √ √ √ × 
Collision Detection √ √ √ × 
IP Settings √ √ × × 
Vision Configuration √ √ √ × 
Follow Configuration √ √ √ × 
Vibration Suppression √ √ √ × 
Local Settings √ √ × × 
Advanced Settings  × × × × 
System Status × × × × 
Hardware Testing × √ × × 
Maintenance √ √ × × 
Debugging Settings √ × × × 

IO 
Detection 

View Physical IO  √ √ √ √ 
Modify Physical Outputs √ √ √ × 
View Virtual IO  √ √ √ √ 
Modify Virtual Outputs  √ √ √ × 
View System IO and Trigger Settings √★ √★ × × 

Plugin 
Navigation 

Create Group √ × × × 
Delete Group √ × × × 
Load Plugin √ × × × 
Unload Plugin √ × × × 
Move √ × × × 
Open √ × × × 

Plugin 
Managem
ent 

Install √ × × × 
Export √ × × × 
Uninstall  √ × × × 
Permission Management √ × × × 

13.5. Modbus TCP Control Interface Data Table 
 Local Address  

Register 
Address 

 Definition Description Remarks 

Send MBDataBuffer[0] 40001 reserved  
Heartbeat detection 
value 

Ranges from 
1 to 65535 in 
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 Local Address  
Register 
Address 

 Definition Description Remarks 

a cyclic 
pattern 

MBDataBuffer[1] 40002 Global speed    

MBDataBuffer[2] 40003   
Read/write flag 
response  

  

MBDataBuffer[3] 40004 
Rob status 
information 

bit0: Manual 
Operation Mode  
bit1: Automatic 
Operation Mode  
bit2: Remote 
Operation Mode  
bit3: Enable Status 
bit4: Running Status 
bit5: Error Status  
bit6: Program 
Running Status  
bit7: Robot in Motion 

 

MBDataBuffer[4] 40005 

Current loaded 
project name 

20 bytes  

For example, 
if the loaded 
project file 
name is 
"estun.test," 
the values of 
each register 
are as follows: 
[4]0x6573,  
[5]0x7475,     
[6]0x6E2E,  
[7]0x6D61,  
[8]0x696E,   

MBDataBuffer[5] 40006 
MBDataBuffer[6] 40007 
MBDataBuffer[7] 40008 
MBDataBuffer[8] 40009 
MBDataBuffer[9] 40010 
MBDataBuffer[10] 40011 
MBDataBuffer[11] 40012 
MBDataBuffer[12] 40013 

MBDataBuffer[13] 40014 

MBDataBuffer[14] 40015 SimDout[1-16] DO 1-16   
MBDataBuffer[15] 40016 SimDout[17-32] DO 17-32   
MBDataBuffer[16] 40017 SimDout[33-48] DO 33-48   
MBDataBuffer[17] 40018 SimDout[49-64] DO 48-64   



 Annex 

 
 

167 

1  

 Local Address  
Register 
Address 

 Definition Description Remarks 

MBDataBuffer[18] 40019 
Rob Command 
Execution 
Status 

bit0: Command is 0 
bit1: Successful 
execution of 
Emergency Stop 
command  
bit2: Successful 
execution of Start 
command  
bit3: Successful 
execution of Stop 
command  
bit4: Successful 
execution of Reset 
command  
bit5: Successful 
execution of Enable 
Up command  
bit6: Successful 
execution of Enable 
Down command  
bit7: Successful 
execution of Load 
Project command  
bit8: Successful 
execution of Logout 
Project command  
bit9: Successful 
execution of Set 
Global Speed 
command  
bit10: Waiting for 
Control  
bit11: Waiting for 
Command  
bit12: Waiting for 
Command Execution 
to Complete  
bit13: Command 
Execution Error  
bit14: Reserved  
bit15: Reserved  

When the 
command 
register is 0, 
bit[0] is 1. 
When the 
command 
register has a 
command, 
bit[0] is 0. 
 
Upon 
successful 
execution of a 
command, the 
corresponding 
success bit is 
set to 1. 
 
When 
regaining 
control and 
the command 
is 0, the 
previous 
success bits 
are cleared. 
 
Therefore, the 
status code 
for issuing 
commands is 
0x801. 

MBDataBuffer[19] 40020 
Use by User AO 1-32 

  
……     
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 Local Address  
Register 
Address 

 Definition Description Remarks 

……     
……     
MBDataBuffer[50] 40051   

Recei
ve 

MBDataBuffer[51] 40052 
Robotic 
Operation 
Commands 

bit2 (0 → 0x4): Start 
robot program 
bit3 (0 → 0x8): Stop 
robot program 
bit4 (0 →  0x10): 
Reset robot errors 
bit7 (0 →  0x80): 
Load project file 
bit8 (0 →  0x100): 
Logout current project 
file 
bit9 (0 →  0x200): 
Set global speed 
bit10 (0 →  0x400): 
Reset command state 
machine 

All commands 
are triggered 
on the rising 
edge and 
should be 
used with the 
read/write flag 
0x11. 
Commands 
can be sent 
when the 
command 
status bit is 
0x801. 
Note: When 
encountering 
a command 
response 
failure, it is 
necessary to 
reset the state 
machine 
using bit10 
before 
sending a new 
command. 

MBDataBuffer[52] 40053 
Global Speed 
Value 

    

MBDataBuffer[53] 40054 

Set Project 
Name 

20 bytes   

MBDataBuffer[54] 40055 
MBDataBuffer[55] 40056 
MBDataBuffer[56] 40057 
MBDataBuffer[57] 40058 
MBDataBuffer[58] 40059 
MBDataBuffer[59] 40060 
MBDataBuffer[60] 40061 
MBDataBuffer[61] 40062 
MBDataBuffer[62] 40063 
MBDataBuffer[63] 40064 SimDI[1-16] DI 1-16   
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MBDataBuffer[64] 40065 SimDI[17-32] DI 17-32   
MBDataBuffer[65] 40066 SimDI[33-48] DI 33-48   
MBDataBuffer[66] 40067 SimDI[49-64] DI 48-64   
MBDataBuffer[67] 40068 

Use by User AI 1-32 

  
……     
……     
……     
MBDataBuffer[98] 40099   

MBDataBuffer[99] 40100 Read/Write Flag   

0x11: Open 
rob Command 
Issuance 
Permission 
(0x11) 

 
 

13.6. Deployment 
The software requires a 64-bit operating system. 

Install the software in a directory without Chinese characters. 

If the 3D plugin is not functioning properly, it is likely that the graphics card driver needs to be 
updated. 
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